setInterval bites the dust!

I hold my hands up, there are some really clear people out in the InterWorld (does that even exist?) and I’m just scratching at the surface.

After doing some cramming on how to implement a Corona SDK style implementation of Box2d-Web into bHive I came across the “new thinking” of how to do intelligent animation. The answer, requestAnimationFrame (silent fanfare!).

As usual the browser gods can’t agree on a unified naming convention, so we’re left with the o-moz-webkit combo of functions, Geesh.. Guys, agree on one name for your functions please!

Rant over, and back to the clever people! Seth Ladd and Paul Irish are these two clever people and have helped me no end with their in-depth explanations, and I have to say it’s given bHive a new boost of speed.

Bye setInterval!


Leave a Reply